Commit d49fc5d4 authored by Jan Groenewald's avatar Jan Groenewald

in aims-release-upgrade disable sources containing ubuntu codenames

parent 394a8fe2
......@@ -32,9 +32,12 @@ echo " * Remove packages that are no longer needed... "
apt-get -y autoremove
# Update to buster
echo "Commencing upgrade from Debian 9 Stretch to Debian 10 Buster."
echo "Updating sources..."
[ -f /etc/apt/sources.list.d ] && mv -f /etc/apt/sources.list.d/jessie.list /etc/apt/sources.list.d/jessie.list.disabled
echo " * Commencing upgrade from Debian 9 Stretch to Debian 10 Buster."
echo " * Updating sources..."
[ -f /etc/apt/sources.list.d/jessie.list ] && mv -f /etc/apt/sources.list.d/jessie.list /etc/apt/sources.list.d/jessie.list.disabled
for i in /etc/apt/sources.list.d/*.list ; do
egrep 'trusty|xenial|bionic|artful|cosmic|disco' $i && mv -f $i $i.disabled;
done
sed --in-place "s/stretch/buster/g" /etc/apt/sources.list /etc/apt/sources.list.d/* 2> /dev/null
echo " * Updating package list..."
......@@ -52,7 +55,7 @@ apt-get $DPKG_OPTIONS --yes --quiet install aims-desktop
echo " * Remove packages that are no longer needed... "
apt-get $DPKG_OPTIONS --yes --quiet autoremove
# R packages must be compiled against current version of R
# R packages must be re-compiled against current version of R
# including the IRkernel we installed for stretch
rm -rf /usr/local/lib/R/site-library/*
aims-install-rstudio
......
aims-desktop (1:2019.07.12) stretch; urgency=medium
* In aims-release-upgrade disable sources containing ubuntu codenames
-- Jan Groenewald <jan@aims.ac.za> Fri, 12 Jul 2019 08:26:33 +0000
aims-desktop (1:2019.07.11) stretch; urgency=medium
* Expand aims-release-upgrade to first update stretch and afterwards remove
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment