Commit 3a1bfd6f authored by Jan Groenewald's avatar Jan Groenewald

Update aims-release-upgrade

parent 59ea0578
......@@ -13,10 +13,10 @@ export DEBIAN_FRONTEND="noninteractive"
# Resume if we have a partial install...
dpkg --configure -a
apt-get -f install || echo "Unable to correct; Please fix your system first." && exit 1
echo "Updating sources..."
sed --in-place "s/stretch/buster/g" /etc/apt/sources.list
sed --in-place "s/stretch/buster/g" /etc/apt/sources.list.d/* 2> /dev/null
sed --in-place "s/stretch/buster/g" /etc/apt/sources.list /etc/apt/sources.list.d/* 2> /dev/null
echo " * Updating package list..."
apt --quiet update
......@@ -32,3 +32,8 @@ apt-get $DPKG_OPTIONS --yes --quiet remove aims-desktop
apt-get $DPKG_OPTIONS --yes --quiet install aims-desktop
echo " * Remove packages that are no longer needed... "
apt-get $DPKG_OPTIONS --yes --quiet autoremove
# R packages must be compiled against current version of R
mv /usr/local/lib/R/site-library /usr/local/lib/R/site-library.stretch
echo "R has been upgraded. Please re-install your locally installed R packages."
echo "You can safely remove /usr/local/lib/R/site-library.stretch"
aims-desktop (1:2019.07.04) stretch; urgency=medium
* Updates to aims-release-upgrade
-- Jan Groenewald <jan@aims.ac.za> Wed, 10 Jul 2019 13:19:35 +0000
aims-desktop (1:2019.07.03) stretch; urgency=medium
* Revert to released rstudio.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment