Commit e0806a81 authored by Jonathan Carter's avatar Jonathan Carter
Browse files

Update aims-release-upgrade

parent 65c07319
#!/bin/sh
if [ "$1" != "-f" ];then
echo "AIMS Desktop 2020.1 has not yet been released,"
echo "add '-f' to continue upgrading anyway."
exit 1
fi
# Keep this for next time.
#if [ "$1" != "-f" ];then
# echo "AIMS Desktop 2020.1 has not yet been released,"
# echo "add '-f' to continue upgrading anyway."
# exit 1
#fi
# Set interface to noninteractive
export DEBIAN_FRONTEND="noninteractive"
#export DPKG_OPTIONS='-o Dpkg::Options::="--force-confold"'
# Resume if we have a partial install...
dpkg --configure -a
echo "Updating sources..."
sed --in-place "s/stretch/buster/g" /etc/apt/sources.list
sed --in-place "s/stretch/buster/g" /etc/apt/sources.list.d/* 2> /dev/null
......@@ -22,7 +26,9 @@ echo " * Performing initial upgrade (safe upgrade)..."
apt-get $DPKG_OPTIONS --yes --quiet upgrade
echo " * Completeing full upgrade (dist-upgrade)..."
apt-get $DPKG_OPTIONS --yes --quiet full-upgrade
echo " * Ensure AIMS Desktop metapacage is still installed..."
echo " * Re-install AIMS Desktop metapacage..."
# re-installing ensures that all recommends, including new ones are installed
apt-get $DPKG_OPTIONS --yes --quiet remove aims-desktop
apt-get $DPKG_OPTIONS --yes --quiet install aims-desktop
echo " * Remove packages that are no longer needed... "
apt-get $DPKG_OPTIONS --yes --quiet autoremove
aims-desktop (1:2019.03.17) stretch; urgency=medium
* Update aims-release-upgrade
-- Jonathan Carter <jcc@debian.org> Wed, 26 Jun 2019 12:43:55 +0000
aims-desktop (1:2019.03.16) stretch; urgency=medium
* Version bump to test reprepro
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment