Commit 1deae374 authored by Jan Groenewald's avatar Jan Groenewald
Browse files

Change keyserver and use gpg instead of apt

parent 8d51ba19
#!/bin/bash #!/bin/bash
apt-key adv --keyserver hkp://keys.gnupg.net --recv-key CD9C0E09B0C780943A1AD85553F8BD99F40DCB31 gpg --keyserver keys.openpgp.org --recv-keys CD9C0E09B0C780943A1AD85553F8BD99F40DCB31
echo 'deb http://www.math.uiuc.edu/Macaulay2/Repositories/Debian buster main' >/etc/apt/sources.list.d/macaulay2.list echo 'deb http://www.math.uiuc.edu/Macaulay2/Repositories/Debian buster main' >/etc/apt/sources.list.d/macaulay2.list
apt-get -qq update apt-get -qq update
apt-get -y install macaulay2 apt-get -y install macaulay2
......
#!/bin/bash #!/bin/bash
echo "deb http://cloud.r-project.org/bin/linux/debian buster-cran40/" > /etc/apt/sources.list.d/cran.list echo "deb http://cloud.r-project.org/bin/linux/debian buster-cran40/" > /etc/apt/sources.list.d/cran.list
apt-key adv --keyserver=keys.gnupg.net --recv-key 'E19F5F87128899B192B1A2C2AD5F960A256A04AF' gpg --keyserver=keys.openpgp.org --recv-keys E19F5F87128899B192B1A2C2AD5F960A256A04AF
apt-get -qq update apt-get -qq update
apt-get -yf install r-base r-base-dev r-recommended apt-get -yf install r-base r-base-dev r-recommended
......
...@@ -4,7 +4,7 @@ ...@@ -4,7 +4,7 @@
#RSTUDIO=https://download1.rstudio.org/desktop/bionic/amd64/rstudio-1.3.959-amd64.deb #RSTUDIO=https://download1.rstudio.org/desktop/bionic/amd64/rstudio-1.3.959-amd64.deb
RSTUDIO=https://download1.rstudio.org/desktop/bionic/amd64/rstudio-1.4.1717-amd64.deb RSTUDIO=https://download1.rstudio.org/desktop/bionic/amd64/rstudio-1.4.1717-amd64.deb
gpg --keyserver keys.gnupg.net --recv-keys 3F32EE77E331692F gpg --keyserver keys.openpgp.org --recv-keys 3F32EE77E331692F
apt-get -qq update apt-get -qq update
apt-get -y install r-recommended libedit2 libssl1.1 libclang-dev libobjc-8-dev libobjc4 apt-get -y install r-recommended libedit2 libssl1.1 libclang-dev libobjc-8-dev libobjc4
cd /tmp cd /tmp
......
aims-desktop (2:2020.98) buster; urgency=medium
* Change keyserver and apt->gpg
-- Jan Groenewald <jan@aims.ac.za> Thu, 19 Aug 2021 11:22:19 +0200
aims-desktop (2:2020.97) buster; urgency=medium aims-desktop (2:2020.97) buster; urgency=medium
* Add /usr/local/bin/julia * Add /usr/local/bin/julia
......
#!/bin/bash #!/bin/bash
apt-key adv --keyserver hkp://keys.gnupg.net --recv-key CD9C0E09B0C780943A1AD85553F8BD99F40DCB31 gpg --keyserver keys.openpgp.org --recv-key CD9C0E09B0C780943A1AD85553F8BD99F40DCB31
echo 'deb http://www.math.uiuc.edu/Macaulay2/Repositories/Debian bullseye main' >/etc/apt/sources.list.d/macaulay2.list echo 'deb http://www.math.uiuc.edu/Macaulay2/Repositories/Debian bullseye main' >/etc/apt/sources.list.d/macaulay2.list
apt-get -qq update apt-get -qq update
apt-get -y install macaulay2 apt-get -y install macaulay2
......
#!/bin/bash #!/bin/bash
echo "deb http://cloud.r-project.org/bin/linux/debian bullseye-cran40/" > /etc/apt/sources.list.d/cran.list echo "deb http://cloud.r-project.org/bin/linux/debian bullseye-cran40/" > /etc/apt/sources.list.d/cran.list
apt-key adv --keyserver=keys.gnupg.net --recv-key 'E19F5F87128899B192B1A2C2AD5F960A256A04AF' gpg --keyserver keys.openpgp.org --recv-keys E19F5F87128899B192B1A2C2AD5F960A256A04AF
apt-get -qq update apt-get -qq update
apt-get -yf install r-base r-base-dev r-recommended apt-get -yf install r-base r-base-dev r-recommended
......
...@@ -2,7 +2,7 @@ ...@@ -2,7 +2,7 @@
RSTUDIO=https://download1.rstudio.org/desktop/bionic/amd64/rstudio-1.4.1717-amd64.deb RSTUDIO=https://download1.rstudio.org/desktop/bionic/amd64/rstudio-1.4.1717-amd64.deb
gpg --keyserver keys.gnupg.net --recv-keys 3F32EE77E331692F gpg --keyserver keys.openpgp.org --recv-keys 3F32EE77E331692F
if [ "$1" != "-n" ]; then if [ "$1" != "-n" ]; then
apt-get -qq update # update unless called with -n, e.g. from aims-complete-install apt-get -qq update # update unless called with -n, e.g. from aims-complete-install
fi fi
......
aims-desktop (1:2022.16) bullseye; urgency=medium
* Change keyserver to keys.openpgp.org and use gpg instead of apt-key
-- Jan Groenewald <jan@aims.ac.za> Thu, 19 Aug 2021 11:19:29 +0200
aims-desktop (1:2022.15) bullseye; urgency=medium aims-desktop (1:2022.15) bullseye; urgency=medium
* typo vscodium -> codium * typo vscodium -> codium
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment